Unable to recognize Skeleton/User [Unity 2018.2.5f1][Mac][OrbbecPersee]


#1

I just started using Nuitrack with Unity and tried setup and build a sample using their “Starting tutorial”, but my build can’t recognize User or Skeleton.

I’m developing on a Mac and haven’t installed the Nuitrack SDK, since apparently is only available for Windows.
I just downloaded the Nuitrack samples, imported the unitypackage on Unity and started coding and building following the tutorial.

Should I have installed the Nuitrack SDK before building the Unity Project?
Is it possible to develop using a Mac?

I’m using the TVico set [Orbbec Persee] and I was successfully able to install the Nuitrack apk and activate my TVico license.


#2

Not sure if you can develop on a Mac, but yea of course you need the SDK.


#3

What do you mean by cant recognise users.
Have you run the sample applications that come with nuitrack?


#4

Hi Guilherme,

Please install TVico.apk instead of Nuitrack.apk as Nuitrack.apk doesn’t provide wireless connectivity.

You don’t have to install Nuitrack runtime component on your Mac. You have to build apk in Unity (“Android” target platform) and then run these APKs on TVico to check skeleton tracking. As an alternative, you can connect your Mac to TVico wirelessly (as described here: http://download.3divi.com/Nuitrack/doc/TVico_page.html#TVico_Desktop) and run the project in Unity editor. In this case, only skeleton data will be transmitted (no user tracking, etc.), this is a current limitation of a wireless case.


#5

I found out what the issue was.
If I tried opening the Nuitrack or TVico apks [any of them two] with the TVico bluetooth ON, both apps would crash.

Since the apps where crashing, I was unable to turn the server ON and so the TVico wasn’t capturing anything.

The solution is: open Nuitrack or TVico apks with bluetooh OFF. As soon as the Server running message appears, close the apks and turn bluetooth ON.

Bluetooth is required for the solution I’m currently working.