Unable to run unity3d build program on raspberry pi


  1. Raspberry pi 4 & 5
  2. 64-bit raspberry pi os
  3. Box64 library to run linux based games
  4. Nuitrack version: 0.37.12 nuitrack-linux-arm64.deb
  5. Unity3D for linux: 2020.3.24f1 personal
  6. Realsense D455 camera with trial license


  1. I want to run a Linux based game that uses nuitrack
  2. The game works seamlessly on linux device
  3. I could successfully test the nuitrack example both using nuitrack app and by executing nuitrack_example


  • When I execute the program it shows System.DllNotFoundException: Unable to load DLL ‘libnuitrack’.
  • Log file
Error loading needed lib libnuitrack
Warning: Cannot dlopen("libnuitrack"/0xc03fd158, 1)
Error loading needed lib libnuitrack.so
Warning: Cannot dlopen("libnuitrack.so"/0x7fffb00fb738, 1)
Error loading needed lib libnuitrack.dll
Warning: Cannot dlopen("libnuitrack.dll"/0x7fffb00fb738, 1)
Error loading needed lib libnuitrack.dylib
Warning: Cannot dlopen("libnuitrack.dylib"/0xc03a0020, 1)
Error loading needed lib libnuitrack.bundle
Warning: Cannot dlopen("libnuitrack.bundle"/0xc03a0020, 1)
Error loading needed lib liblibnuitrack.so
Warning: Cannot dlopen("liblibnuitrack.so"/0xc03a0020, 1)
Error loading needed lib liblibnuitrack.dll
Warning: Cannot dlopen("liblibnuitrack.dll"/0xc03a0020, 1)
Error loading needed lib liblibnuitrack.dylib
Warning: Cannot dlopen("liblibnuitrack.dylib"/0xc03a0020, 1)
Error loading needed lib liblibnuitrack.bundle
Warning: Cannot dlopen("liblibnuitrack.bundle"/0xc03a0020, 1)
System.DllNotFoundException: Unable to load DLL 'libnuitrack': The specified module could not be found.
  at nuitrack.NativeNuitrack.Release () [0x00000] in <00000000000000000000000000000000>:0 
  at nuitrack.Nuitrack.Release () [0x00000] in <00000000000000000000000000000000>:0 
  at NuitrackManager.StopNuitrack () [0x00000] in <00000000000000000000000000000000>:0 
  at NuitrackManager.OnDestroy () [0x00000] in <00000000000000000000000000000000>:0 
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)

https://github.com/3DiVi/nuitrack-sdk/tree/master/Examples/nuitrack_csharp_sample. This program runs successfully.

Hello, @kcyugesh.

Make sure your NUITRACK_HOME is pointing correctly. Also, check if LD_LIBRARY_PATH contains
/usr/local/lib/nuitrack folder. If not, you can export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/local/lib/nuitrack for a single session. If nothing aforementioned helps, could you, please, tell us about your build process in detail?

We’re eagerly waiting for the feedback.

  1. NUITRACK_HOME is pointing to ‘/usr/etc/nuitrack’
  2. LD_LIBRARY_PATH is pointing to /usr/local/lib/nuitrack
  3. The build process is as follows

Hey, @kcyugesh.

Thank you for providing the info. We’ll take it for further investigation
and inform you if there’s any news.

1 Like

Hello, @kcyugesh.

Apologies for the late reply. The forum was down for some time.

We’ve been trying to reproduce your issue but have had no luck. Tell us, please, have you tried to follow this tutorial? Also, could you, please, provide us with a minimal sample and the order of actions leading to the problem? It is the only way for us to identify the problem as quickly as possible.

Thank you for your interest in the Nuitrack. Looking forward to your response.

Hello, @kcyugesh.

How’s it going? Has your issue been solved?

1 Like