Unable to use any nuitrack samples


I’ve just gotten started with the NuiTrack SDK and am having issues using the provided samples. When attempting to use the samples I recieve the error:

Usage: nuitrack_console_sample [path/to/nuitrack.config]
WARNING: Can not load library module: /usr/etc/nuitrack/middleware/libNuitrackModule.so
ERROR: Empty factory for DepthProvider
Can not initialize Nuitrack (ExceptionType: 2)

I am not using the path to the config as it was suggested in another thread that this was not necessary (although I have tried with an without the config.) I am running on Ubuntu 14.04 with the AMD64 deb installer. I have read all of the other threads I could find here and on the Orbbec forums but there has been no success yet!

Thanks for your assistance!

Make sure you have setup the environment variables outlined in the installation documents.
Without these setup correctly the samples will not behave.

Hey Westa! It seems like I’ve seen you on nearly every forum post here. I have the environment variables set up as according to the install instructions and both variables are set to the correct directory.

I am still having this issue and would appreciate any help!

Make sure you have all the perquisite libraries installed - https://www.sfml-dev.org/ in particular has been reported as an issue by some orbbec users


I can’t seem to find any documentation on the prerequisite libraries required for the NuiTrack SDK would you happen to know where I can find a list? I’ve installed the SFML library and still no luck.

Thanks for all your help thus far!

Hi rswann,

We’ve replied you through our support service.

To use Nuitrack on Ubuntu 14.04, you have to upgrade libstdc++6 package (Realsense2Module requires newer version of GLIBCXX). To do this, run the following commands:

sudo -E add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install libstdc++6