Unity and Sample App Rgb mode Not Working

RGB mode in NuiTrack sample(click to toggle to RGB) and other tutorials apps which is using Rgb are not working.

With sample app nuitrack_sample is working good with depth point but as i am clicking on screen to toggle to RGB it freezes.

and with Tutorial apps in Unity All rgb based apps showing a White screen with a skeleton as in picture.

Hi Tapan,

What is your sensor?

Astra Pro ORBBEC Depth camera

You have to enable RGB stream for Astra Pro. To do this, set “CameraID” option in the nuitrack.config file (usually it’s 0, but if it doesn’t work, try 1, 2, …).

Hi, OIga … as you suggested i tried with different camera ids still same. and one more thing the default value was -1 for me. I am not sure why it was like that. Is there any other solution ?

For cameraid -1, 1, 2, 3 worked same way, Depth camera got worked when tried to switch (to rgb) it freezes. and for 0 cameraID black screen came no preview.

Try to plug in your sensor using USB 2.0 and USB 3.0.

Hello, i had the same issue, I followed Olga’s recommendation, more precisely:
1 - Change the CameraID” value option in the nuitrack.config was -1 (default) to 0.
2 - Change the AStra Pro camera from USB3.0 to USB2.0 port.
It works for me.