Unity crashes when performing a drag and drop operation

Same problem. I didn’t know how to reproduced but it is true, If the camera is connected , and I run unity once or twice and I try to drag something unity crashes. What can we do? it is really annoying

We’re investigating this issue at the moment.

1 Like

@olga.kuzminykh how is the updated coming along. I can’t use this plugin if my Unity crashes every hour?

Try to work around the dragging for now, and if you need to, save it before.

This is not a viable solution. You need to use drag and drop for:

  • additive scenes
  • prefabs

Prefabs can be selected without dragging. I also said try to work around it for now, not that it’s a solution.

1 Like

The issue also happens when you use Unity for an extended period of time, so it definitely seems like a memory issue.

Please fix this soon!

It is a memory issue indeed, it’s Nuitrack not cleaning up their data. Cause when using normal Unity I never have this problem.

I wonder if they are going to fix it. Seems odd that it’s been months and still no fix.
Hopefully other developers can see this post before they plan to invest in this SDK.

Any update for this bug?

We’re investigating what causes the crush at the moment.

Do you have a real update ather then a copy and paste from 24 days ago ? This is a no go crash for a lot of licenses… I can not start an arcade game production with this bug.


Update please!

How can you promise Biometric ID and Nuitrack AI - New generation algorithms based on deep learning if you can’t fix a major bug in the system that was reported in November 2018 :confused::angry:

We’ve finally found what caused this problem. It’s connected to the librealsense library (error during the closing of the COM library). We’ll fix this bug in the next Nuitrack release (next week). Sorry for inconveniences.

i have the same crash. it’s possibile while waiting bug fixing release disable librealsense if i’m using kinect v2?

Nuitrack 0.28.0 was released yesterday. In this version, we fixed the drag-and-drop issue in Unity. Besides, we created Nuitrack personal account and changed licensing procedure. Please update Nuitrack and follow the instructions below:

Hi @olga.kuzminykh ,
Is this an update to the Unity SDK or the SDK that is installed directly on the computer?
I updated the SDK in my Unity project and am still having crashes :confused:

Please update Nuitrack Runtime to 0.28.0 as well. In this version, we created Nuitrack personal account and changed licensing procedure. Please reactivate Nuitrack as described above.

Have the same problem, can someone help me please?

Please provide us with the following info:

  • OS
  • Nuitrack version
  • Your sensor
  • А detailed description of the problem