Unity crashes when performing a drag and drop operation

Steps to reproduce:

  1. Init nuitrack and open the sensor
  2. Release nuitrack and stop play mode
  3. Drag any file from the project window/in-game scene asset and the editor crashes

@olga.kuzminykh Update, please.

Hi Ashish,

We’ve followed this procedure on different PCs, however, we couldn’t reproduce this issue. We’re still investigating this. It would be great to have any other details regarding this problem.

Hi Olga,

I have attached a video of the problem I’m facing. Most of the time Unity crashes when doing a drag and drop function but sometimes it doesn’t let me drag and drop anything at all. It’s a fresh project, btw.

It seems that this issue is connected to the Unity interface. Please try the following: when drag-and-drop is blocked (as shown in the video), go to Window/Layouts and select any Layout. After that, drag-and-drop will be unblocked and you’ll be able to continue your work (until the next Unity restart).
You can also contact Unity support with this problem.

Thank you. Works wonderfully well

This problem is not really on Unity’s side. I too have this problem. Whenever the camera is connected and has used Nuitrack once or twice it seems to crash unity the next time I drag something.

Have the same problem, please fix.

1 Like

I think it’s a memory issue as I also seem to get bluescreens at times when the camera is connected, liked to memory. Not sure if this is directly Nuitracks fault or Intels fault with the camera. But i’m leaning towards Nuitrack.

It only happens when Nuitrack is installed. Please fix this issue.

It’s most likely a memory issue. Nuitrack is somehow piling up data in the background. Also causing me to have the occasinal blue screen, only when nuitrack has run at least once.

Same problem. I didn’t know how to reproduced but it is true, If the camera is connected , and I run unity once or twice and I try to drag something unity crashes. What can we do? it is really annoying

We’re investigating this issue at the moment.

1 Like

@olga.kuzminykh how is the updated coming along. I can’t use this plugin if my Unity crashes every hour?

Try to work around the dragging for now, and if you need to, save it before.

This is not a viable solution. You need to use drag and drop for:

  • additive scenes
  • prefabs

Prefabs can be selected without dragging. I also said try to work around it for now, not that it’s a solution.

1 Like

The issue also happens when you use Unity for an extended period of time, so it definitely seems like a memory issue.

Please fix this soon!

It is a memory issue indeed, it’s Nuitrack not cleaning up their data. Cause when using normal Unity I never have this problem.

I wonder if they are going to fix it. Seems odd that it’s been months and still no fix.
Hopefully other developers can see this post before they plan to invest in this SDK.