Unity doesn't receive any user data


I’m testing Nuitrack on Unity with a RealSense L515. While I’m able to turn on the device and see the RGB background when I try the “First Unity Project” tutorial I don’t receive any user data, so It never displays the skeleton. On the other hand when I run the Nuitrack test application I can see the skeleton overlay.
In the Unity side there’s no errors on console, all seem to work except it’s not receiving any user data.

Any clues?

Hello @bruno.barran
Run AllModuleScene from our package

Thanks for the quick replay. Have run it. Seems to work but no having any skeleton output.

This is the output of “First project” scene

The First project tutorial does not display a skeleton on an RGB background.

To see the 2D skeleton and RGB, you can use prefab NuitrackSDK/Frame/Prefabs/Sensor Frame Canvas.prefab or tutorial Displaying Skeletons on an RGB Image.

To study 3D avatars against an RGB background, see tutorial Virtual Fitting Room.

See also General Preparations

Thanks Eugene. The First project is not even recognizing any user and if I run “Displaying Skeletons on an RGB Image” tutorial I only get the RGB image without the skeleton overlay. Is there any configuration that I have missed?

Also if I run the Nuitrack sample app I get the skeleton.

Are you using the latest version of NuitrackSDK and NuitrackSDK.unitypackage?

Try to move away from the sensor, so that the whole body fits into the field of vision of the sensor.

Yep, using the latest from github 0.35.12. Trying the whole body outputs the same…

I realized that when I was trying the Nuitrack SDK I was using the AI skeletal tracking.

Without this option I don’t get any skeleton tracked. I followed the General Preparations but I haven’t improved the result.

Maybe there’s an issue with the L515?


@bruno.barran hm… can you send Unity editor log?

1 Like

Hello @bruno.barran
Problem solved?