Unity Example Not Working


I’m trying to set up a project on Windows 10, using 64 bit Unity 5.5.0f3. I’m using a Primesense depth camera.

I’ve set up the path variables and done the activation, and the nuitrack_c11 sample works as expected.

If I do a clean Unity install and then import the SDK unity package, I get this:

Because of these errors, the project can’t be built or tested.

Scrolling through, it looks like every reference to “nuitrack” is throwing an error. Is there something extra setup step I’m missing?

Thanks for your help,

Hi Andre,

Please, try to select Nuitrack SDK/Nuitrack/NuitrackAssembly/nuitrack.net.dll (in Unity) and tick “Any Platform” in the Inspector tab. This issue may occur in case this value is unticked.

Thank you! That seems to have fixed that issue, and the project now doesn’t display errors. Unfortunately, when I try to run the example “allModulesScene” scene, I get this error.

Is this an indication that it’s not connecting to the device correctly? Or maybe the path is configured incorrectly?

Thanks again!

Hi Andre,

Make sure that only one sensor is connected to your PC.

Also, please:

  1. try to open any other scene from the ‘Tutorials’ folder
  2. check the C# sample in Nuitrack SDK: do you still encounter BadConfigValueException?

Definitely only the primesense tracker is connected (plus an external mic and a VR headset, but I’m assuming those shouldn’t interfere).

It looks like the BadConfigValueException still pops up in the tutorial scenes, and after setting up the C# example in the SDK, I get what appears to be the same error.

Is this an indication that I didn’t setup the SDK correctly?

Hi Andre,

It looks like you have not setup the nuitrack runtime correctly - this needs to be installed as well as the SDK,

To setup the runtime - look at the install notes in the documentation - and make sure you have the NUITRACK_HOME environment variable pointing to the right place … and nuitrack/bin setup in your environment PATH.

Once you do that - go into the activation_tool folder and run the nuitrack.exe file found in there.
It includes a TEST button that will verify your installation is correctly setup.



I have installed nuitrack runtime, I believe, and I just double-checked that the environment variables are set correctly. The test button in the activation thing works correctly, but still no luck getting the other examples to work.

Any thoughts on what else to try? I guess I can try setting it up on another machine, try to narrow down the possible sources of failure.

That error would definitely suggest that the NUITRACK_HOME environment variable is not set correctly
Try opening a command window (cmd.com) and typing echo %NUITRACK_HOME%
Make sure the value points correctly to the root of your nuitrack folder path c:\Nuitrack or something like that.

Also maybe make sure that the environment variable is set to entire system - not just you - and further make sure you reboot after setting the value and check it again after reboot in cmd.com window.


Oh and its likely case sensitive - make sure capitals etc are correct


Aha! It was set up for the wrong user account originally, and I never rebooted after I changed it. That finally fixed it, and it seems to be working now.

Thank you so much for your help, I really appreciate it.

I was following this and other threads to try and get the unity examples to run (windows 10. 64. Real sense D415. Unity 2017.4.7f1) but I seem to have hit a wall. Is it ok to post here or should I start a new thread?

nuitrack_c11_sample.exe runs and displays a depth stream.
Nuitrack.exe also runs and displays the Compatibility Test.
The specific error that I get is DllNotFoundException: libnuitrack nuitrack.NativeNuitrack.Init (System.String config) nuitrack.Nuitrack.Init (System.String config, NuitrackMode mode) NuitrackManager.NuitrackInit () (at Assets/NuitrackSDK/Nuitrack/NuitrackManager.cs:183) NuitrackManager.Awake () (at Assets/NuitrackSDK/Nuitrack/NuitrackManager.cs:110)
I have the nuitrack.net.dll set to any playform and both 86 and 64 bit. (turning off 86 does not fix the problem)

The Intel Realsense Viewer and unity SDK are both connecting to the camera and displaying depth data.

I have upgraded the Realsense firmware to

%NUITRACK_HOME% echos out “C:\nuitrack” and is set for both the user and the system. That folder includes the activation_tool, bin, data, and middleware folders.

I also ran ““C:\Program Files\OpenNI\Bin64\niReg64.exe” -r C:\nuitrack\bin\libnuitrack_ni.dll C:\nuitrack\data” in the command line and got no error response.

Hi BriskFx,

Unity requires 64-bit version of Nuitrack runtime component. Please make sure that you’ve installed nuitrack-win64.zip

Also make sure that you’ve added the path to the %NUITRACK_HOME%/bin folder to the PATH environment variable.

1 Like

I have set the NUITRACK_HOME to C:\nuitrack\bin and C:\nuitrack\ and neither of them work. I get the same error.

I also verified that I had put the contents of nuitrack-win64 to the C:\nuitrack\ folder.

If you unpack nuitrack-win64.zip to C:\nuitrack\, then the structure is as follows:

              ├── nuitrack
              ├── *.msi
              └── README.txt

So, NUITRACK_HOME should be equal to C:\nuitrack\nuitrack

I have figured out my problem. It was related to then PATH variable. It is really easy to miss the 2nd environment variable halfstep in the docs.

Note, the system will work if you unpack to C:\ and set NUITRACK_HOME to C:\nuitrack.

1 Like

I am facing similar issue.
when I play nuitrack example scenes, unity crashes.

I have installed Nuitrack as per documentation, even the nuitrack c11, is working properly.

Kindly help.

Hi mubeen,

Please advise:

  1. What sensor do you use?
  2. What is your Nuitrack version?
  3. What is your Unity version?
  4. What license do you use?
  5. Are there any errors in the Unity log? If yes, send us the screenshot.