Unity + Nuitrack/realsense build not working

Good evening, i have a problem with a Unity application on Windows. Editor project and nuitrack samples (including the realsense viewer) are all working perfectly but when i build the application ( Mono , Net 2.0 ) for winx86 i run the .exe and the camera is not working , i can 't see those red points on the depht sensor turning on like they are doing on all the other samples. What should i do ? I already tried building on Net 4.x but no better result . Thank you for your help.

Please advise what Nuitrack you have installed? x86 or x64?

Hello again, sorry for wasting your time . I realized after many hours that i must set the target build for the application to x64 and not x86 and then it just works perfectly.

@iosif.semenyuk yes i have installed the x64 so it should match also in the application ( i think ). Anyway thank you for the answer.

i have the same issue, posted a question Nuitrack works on Unity Editor, but not when building the game