Unreal 5.32 - Will not function, compile. Assets missing from Demos

I must be missing something very obvious.
I am using UE5.32 Win10
The current UITrack UEPlugin for v5.2 or higher.
WINx64 Nuitrack, activated and demo’d with Azure Kinect (1.41sdk). Tested with AZViewer.

Activate sensor with success.
Launch UE - Blank Scene. Content/Open in Explorer and create Plugins. Copy/Paste UEPlugin folder into content. (UE asks to import assets. I accept). Close scene. Relaunch scene.

I go to Fitting Room and launch fitting room: black screen. No assets appear. No objects in the outliner? Just lights. Nothing else.

I have tried this a few ways. Same result.
I must be overlooking something really obvious…

Hello @Doc_Jim

UE asks to import assets. I accept). Close scene. Relaunch scene.

I think this is the problem here

Let’s try from the beginning

  1. Create a new project. Run it. And close it
  2. Create a Plugins folder in the project folder. And copy the Nuitrack plugin there
  3. Launch your project. If you are asked to recompile, then try one of these steps: Error integrating Nuitrack - Unreal Engine 5 - #2 by Stepan.Reuk

Did you install the plugin following the instructions in this video?

Also check it out for sure:

  1. If you click “Try Nuitrack” in the activation tool, you will see a depth map, right?
  2. If everything is fine in the first step, then start the scene and check the Output Log. Is there any useful information there? (you can drop it here)
    For example
  3. Check the list of plugins, is Nuitrack displayed there? (Settings\Plugins)

Thank you very much! I definitely wish to get this working and appreciate the help!

When I run and activate Nuitrack is sees my sensor and gives me a depth map fine. No errors.

I did exactly as you said…and here are some screen shots of what happened when I re-opened the project…and after trying to execute.

Ok…I see that I installed the Plugins folder inside the Content folder of the project. This created all these errors.

When I install the Plugins folder in the root of the Project,…then I get the same errors as here:
Error integrating Nuitrack - Unreal Engine 5 - #2 by Stepan.Reuk

In my case the project will not Open if I choose Ignore Rebuild. It will not Open if I choose Rebuild. Gives me errors.
Unfortunately I am new to Unreal and have to learn how to recompile as you suggest.
I have always used Unity with the Rumem Filkov scripts and just now transitioning to Unreal and need this functionality.

1 Like

I am glad to hear that you have managed to solve this problem.
Regarding the recompilation, we will definitely deal with this and release the update as soon as possible. Now the fastest and easiest way is to install the Unreal Engine version 5.2.0, in which case recompilation is not required (the plugin has already been compiled for this version)

@Doc_Jim Did you manage to launch the plugin?

I also want to tell you the good news. A new version of the plugin has been released in beta:

  • simplified building. Now you don’t need to edit any files, just do the build.
  • in README.txt added instructions on what to do if Unreal Engine requests a rebuild. Check out the Plugin Rebuilding section

:firecracker: New Version Beta Nuitrack UE5 plugin https://bit.ly/nuitrack-unreal-engine-5