Windows Installation problem


#1

Hello Lovely Nuitrack people,

Upon installing the x64 installer as administrator windows installer on my core i7 lappy (with a fancypants GTX1060 no less!), I am faced with the following error.
I have tried disabling Anti-Virus, Restarting PC a few times, Explicitly running as administrator, all to no avail.

“Error during installation process (com.3divi.nuitrack):
Execution failed (Unexpected exit code: 87): “cmd /C icacls C:\Program Files\Nuitrack3\nuitrack\nuitrack\data /grant %USERNAME%:F /T””

Many Thanks in advance, Any Suggestions?


#2

Hi NicestDaemon,

Can you skip this step? (Error during installation process…)
If yes, skip this step, wait for the installation is finished and run the following command from Windows PowerShell as Administrator:

cmd /C icacls "C:\\Program Files\\Nuitrack\\nuitrack\\nuitrack\\data" /grant %USERNAME%:F /T


#3

Good Morning Olga,

Thanks for the speedy response.
Ah-ha, you’re right it appears that the installer/Powershell/Windows has an issue with %USERNAME% if the windows username contains spaces! Installation is now clean.

Next issue (I was seeing this previously also): When running the Nuitrack in the activation_tool directory. The Compatability test merely produces a black window, with a smaller white box inside. I’ve left it for some time and the status does not change.

Any suggestions?

Thanks and best Regards


#4
  1. Did you log out to let the system changes take effect?
  2. Please run nuitrack_sample from %NUITRACK_HOME%/bin and provide us with the console output.

#5

Good Morning Olga,

Thanks for the hints.
We finally realised that the compatability test will pass, as long as there is appropriate 3D Camera hardware already attached to the machine!
If there is no 3D Camera connected to the pc, the test will hang indefinitely.

The box to enter the license still remained grey after the test passed, but we tried a few more times, and it became available.

No futher issues, Thank you!


#6

I’ve tried to run this cmd /C icacls "C:\\Program Files\\Nuitrack\\nuitrack\\nuitrack\\data" /grant %USERNAME%:F /T from the powershell but I get invalid parameter

Not sure what’s goin on


#7

Alright mark - does your windows account/user name have two words?
It wasn’t working for me cos there was a space in the username. I created a new account with just one work and hey presto - shes worked a treat!

HTH