Astra plus not found on Ubuntu 18.04 (orbbec examples work)

I made another post yesterday related to windows installations but I found out that orbbec didnt have drivers for my computer. So I switched to Ubuntu 18.04 and got the orbbec examples to work. Unfortunately Nuitrack cant see the camera. Is there any additional setups needed?

Nuitrack console sample recognizes the camera but it messes up the path to it.

Camera is connected to: Bus 002 Device 005: ID 2bc5:0636

Nuitrack tries to connect to: “2bc5/0636@2/5”

That @ sign should not be there right?

Hi Max!
Sorry for the issues you’ve encountered!
It could be the problem with permission, try running the following command

sudo chmod -R 777 /dev/bus/usb/

Looking forward to your response.

1 Like

I thought so too but still no success. I tried to connect the Realsense d435 to the same computer and i just works with Nuitrack.

Could the Orbbec installation package interfere with Nuitrack?

Dear Max,
What nuitrack version do you use?
Do you use the original cable with your sensor? If not, try using it to see if that solves the problem.
Could you please run ldd /usr/bin/nuitrack_sample and ldd /usr/bin/QtNuitrackLicense in cmd and send us the output.

Looking forward to your response.

Ok! Thanks for all the help!

Version is 0.35.10

Output of ldd /usr/bin/nuitrack_sample: (0x00007ffc10b64000) => /usr/local/lib/nuitrack/ (0x00007fb77e015000) => /lib/x86_64-linux-gnu/ (0x00007fb77de0d000) => /lib/x86_64-linux-gnu/ (0x00007fb77dbee000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb77d962000) => /lib/x86_64-linux-gnu/ (0x00007fb77d745000) => /usr/local/lib/nuitrack/ (0x00007fb77d16b000) => /usr/local/lib/nuitrack/ (0x00007fb77cb9c000) => /usr/local/lib/nuitrack/ (0x00007fb77c6a6000) => /usr/local/lib/nuitrack/ (0x00007fb77c45d000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb77c0d4000) => /lib/x86_64-linux-gnu/ (0x00007fb77bd36000) => /lib/x86_64-linux-gnu/ (0x00007fb77bb1e000) => /lib/x86_64-linux-gnu/ (0x00007fb77b72d000) => /lib/x86_64-linux-gnu/ (0x00007fb77b529000)
/lib64/ (0x00007fb77e604000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb77b2f8000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb77b042000) => /usr/local/lib/nuitrack/ (0x00007fb77adbe000) => /usr/local/lib/nuitrack/ (0x00007fb77ab56000) => /usr/local/lib/nuitrack/ (0x00007fb77a933000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb77a5fb000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb77a3eb000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb77a1e5000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb779fbd000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb779dab000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb779ba7000) => /usr/lib/x86_64-linux-gnu/ (0x00007fb7799a1000) => /lib/x86_64-linux-gnu/ (0x00007fb77978c000)

Output of ldd /usr/bin/QtNuitrackLicense:
/usr/bin/QtNuitrackLicense: /usr/lib/x86_64-linux-gnu/ version `Qt_5.11’ not found (required by /usr/bin/QtNuitrackLicense) (0x00007ffdfbdb2000) => /usr/local/lib/nuitrack/ (0x00007f900ea13000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900e1cc000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900da63000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900d318000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900cf8f000) => /lib/x86_64-linux-gnu/ (0x00007f900cd77000) => /lib/x86_64-linux-gnu/ (0x00007f900c986000) => /lib/x86_64-linux-gnu/ (0x00007f900c767000) => /lib/x86_64-linux-gnu/ (0x00007f900c563000) => /usr/local/lib/nuitrack/ (0x00007f900bf89000) => /usr/local/lib/nuitrack/ (0x00007f900ba93000) => /lib/x86_64-linux-gnu/ (0x00007f900b6f5000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900b469000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900b237000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900af99000) => /lib/x86_64-linux-gnu/ (0x00007f900ad7c000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900a8db000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900a523000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900a312000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9009ffb000)
/lib64/ (0x00007f900f002000) => /usr/local/lib/nuitrack/ (0x00007f9009d77000) => /usr/local/lib/nuitrack/ (0x00007f9009b0f000) => /lib/x86_64-linux-gnu/ (0x00007f9009907000) => /usr/local/lib/nuitrack/ (0x00007f90096e4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f90094b3000) => /usr/lib/x86_64-linux-gnu/ (0x00007f90091fd000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9008f49000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9008d1c000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9007173000) => /lib/x86_64-linux-gnu/ (0x00007f9006f01000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9006bc9000) => /usr/lib/x86_64-linux-gnu/ (0x00007f90069a1000) => /usr/lib/x86_64-linux-gnu/ (0x00007f900679d000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9006597000) => /lib/x86_64-linux-gnu/ (0x00007f9006382000)

Dear Max!
Could you please tell us: are you using nuitrack in a container cause nuitrack doesn’t work in it.

Also, did you manage to run nuitrack on Windows with Astra Plus? Cant find the Orbbec Astra plus


No i didnt manage to get it running on Windows at all. Not even the Orbbec samples. The driver was incompatible.

I followed this guide:

And I didnt change anything. But i’m gonna try reinstalling ubuntu now and just install nuitrack, not Orbbec. Think I’ve hade issues with a previous setup where I installed realsense sdk and Nuitrack.

Edit: I did a fresh install now and installed nuitrack by the guide. The realsense d435 camera works directly and the Astra+ has the same issue as before. Mind that I haven’t installed anything else now. Nothing from intel or Orbbec.

Thanks again!

Hi Max!
We sent you an email, please contact us.