"AstraProPerseeDepthProvider" is not used in Astra Pro


#1

Hi,
I am currently trying to display skeleton and RGB images simultaneously using “Astra Pro”.
I am developing on Windows.

To enable RGB stream for Astra Pro, you should set “CameraID” option in the nuitrack.config file (usually it’s 0, but if it doesn’t work, try 1, 2, …).

However, I am in trouble because the RGB image is not displayed even if I do the above.

As a result of confirmation, “OpenNI2DepthProvider” is used at startup, and I think that CameraID is not reflected.

Is there any solution?
Thanks in advance.


#2

Hi Lily_nut,

Make sure that you allowed apps to access your camera: select Settings → Privacy → Camera and turn on “Allow apps to access your camera”. Besides, your antivirus software may block the application, you can try to turn the antivirus off for some time.
What values did you set in "CameraID"?
And also check that your sensor is detected and displayed in the device manager.