AzureKinect DK nuitrack.config isnt applying

Hey i’m trying to set RGB to a larger resolution than 640x480 with no success. Unity 3D with nuitrack license newsest sdk’s and firmwares.
A working config for the device would be nice :slight_smile:

sensor In nuitrack program:
Azure Kinect DK(AzureKinectDepthProvider)


on a side note my Realsense D455 config is working perfectly, I can adjust the values

Any other way of changing the width and height from c# unity would also work for me.

Any help would be appriciated :slight_smile:

Hi @Klavs,
Change nuitrack.config like this:

    "AzureKinectDepthProviderModule": {
        "OutputWidth": 1920,
        "OutputHeight": 1080

or you can use api functions setConfigValue like this:

Nuitrack::setConfigValue("AzureKinectDepthProviderModule.OutputWidth", "1920");
Nuitrack::setConfigValue("AzureKinectDepthProviderModule.OutputHeight", "1080");

Use nuitrack_device_api_sample to get the available image resolution like this Problems with Astra+ - #2 by irakli

1 Like

Thank you really much <3
this worked, if you dont mind to tell me on how to also depth setting for this it would be great.
I will check out the “nuitrack_device_api_sample” hope I will get answers from there (like a full list of settings for config i can apply, depth, color, rotation, framerate, etc. ):slight_smile:

And im pretty sure that mirror mode isnt working on Nuitrack Manager unity for the Azure kinect DK device

Hi @Klavs,

  • If you want to change the FPS add to the config:
    "FPS": 30, // 30, 15 or 5. If other value is set -> resets to default 30 or 15

  • To change source color resolution add to the config:
    "ColorResolution": "1536P" // suffixes of k4a_color_resolution_t enum // if invalid suffix -> resets to 1536P.

  • To change source depth resolution add the config:
    "DepthMode": "WFOV_2X2BINNED", // suffixes of k4a_depth_mode_t enum // if invalid suffix -> resets to WFOV_2X2BINNED

  • At the moment, Rotate and Mirror is not supported for the Azure DK sensor. Sorry for inconvenience.

Hi @Klavs,

Has your issue been solved? Do you have any other questions that I can help you with?