It seems to be something crahsed with Unity

I Imported Nuitrack SDK to Unity project (Nuitrack SDK version .3515?, Unity version 2020.3.7f1)

My Unity program has some problems after that.

Firstly, It is invisible “Play Button” Tab on started. (I can see “Assertion failed” error on Console tab)
so I should press “Ctrl+P”.
and tab is showed after that.

Secondly, I can’t use to build button from Unity project. if I click the button, It is freeze.
and I have to turn off the unity, through windows task manager.

I thought my Unity program had something wrong at first.
so I re-Installed unity hub and unity program. but It was not worked.
And my co-worker Installed and Imported Nuitrack SDK either.
that computer was happend a same problem. so I was convinced Nuitrack SDK has something problem.

Hello @smtsb
Hm… Are you using the latest version of the package from github? nuitrack-sdk/Unity3D at master · 3DiVi/nuitrack-sdk · GitHub

yes, I changed the latest version from github there.
but It still has same problem. and I can see the same version before (ver.3515)

I have tested these versions of nuitrack and unity and everything works well.

  1. Which sensor do you use, have you tried with another sensor (or wire, or usb 3.0 port)?
  2. Can you show the editor’s log?
  3. Have you tried running on a clean version of the OS?
  1. I have tried to use Intel Realsense D435i. unfortunately I don’t have another sensor.
    (wire and usb3.0 ports are working correctly. I tried to other wires and other ports, other usb3.0 device.)
    but I don’t know why it has problem about the device.
    In my opinion, there should be no problem without the device.
    and I’m sure my realsense device doesn’t have any problem.
  2. you can check my previous post. It had the same problem back then already.
  3. I can’t format drives to try to run in my situation now.

and I found same problem.
but It looks not solved.

Hm… Try to do this:

  1. Create a new project

  2. Import this experimental package NuitrackSDKPortableBeta.unitypackage - Google Drive

  3. Make sure that the log says “portable”

  4. Test. Select the item in the menu “Nuitrack\Play Test Unity Scene”

  5. Activate the license. Select the item in the menu “Nuitrack\Activate Nuitrack”

@smtsb Has your issue been solved?

It didn’t have any problems in new empty project.
but It has problems on my specific project only.
It seems to be crashed with other assets.
I was testing about that. but I couldn’t resolve.

And I tried to change existing package to portable package, but It was same.

@smtsb You can send us a minimally reproducible example of your project, we will try to investigate the problem.

Hello @Stepan.Reuk , thank you for waiting this topic.

I found what is the problem.
please check this.

You can Import the package through “Window>Package Manager>Packages:Unity Registry>find the [ProBuilder]” in tab of Unity.

I tested ProBuilder v4.5.0 with Nuitrack v0.3515 in HDRP project (Unity v2020.3.7f1)
I added only two of them, that trouble was happend.

It seems to be solved in ProBuilder v4.5.2 (Verified) and newer.
(but It has trouble in ProBuilder v5.0.1, v5.0.3 also, because It was older than v4.5.2)

and I could solve the problem using also other Unity version.

Thank you

1 Like