Nuitrack.Init throws Exception in Unity

Hello there,

I get this Exception when running Nuitrack Unity Example.
Does it ring any bell?
I saw lots of similar topics in this community, but all of them are different to my case. they didn’t help.

TerminateException: NuitrackException (TerminateException)
nuitrack.NativeImporter.throwException (nuitrack.NativeImporter+ExceptionType type) (at :0)
nuitrack.NativeNuitrack.Init (System.String config) (at :0)
nuitrack.Nuitrack.Init (System.String config, nuitrack.Nuitrack+NuitrackMode mode) (at :0)
NuitrackManager.NuitrackInit () (at Assets/NuitrackSDK/Nuitrack/Scripts/NuitrackManager.cs:221)
NuitrackManager.Awake () (at Assets/NuitrackSDK/Nuitrack/Scripts/NuitrackManager.cs:119)

Sensor Device: Intel D435
Nuitrack Trial License
Nuitrack Version: 0.33.0
Nuitrack SDK: 1.7.0
nuitrack_c11_sample.exe and nuitrack_sample.exe, both run without problem
NUITRACK_HOME is set to correct path (*where there are bin, data, middleware and activation_tool folders)
Path is set to bin folder in NUITRACK_HOME
Tried Box, BasicSkeleton and Humanoid Animation scenes.
Unity 2019.4.9f1

Reinstalling Nuitrack SDK and rebooting several times solved the problem magically…

As it turned out, Nuitrack 0.33.0 downloaded from is a problem. It causes Exception upon Nuitrack.Init mentioned above.
Whereas Nuitrack 0.32.0 downloaded from installation document here has no problem.

I’m using Nuitrack Skeleton Tracking downloaded from Unity Asset Store. which is version 1.0.2

Make sure that the Nuitrack Runtime and Unity package are up to date

I originally downloaded the files suggested by @iosif.semenyuk above. the unity package included in the sdk would not import into unity.
then i downloaded the skeleton tracker package from the unity store. this imported successfully, but unity would throw an exception whenever i ran an example.
finally, i ununstalled 0.33 and installed 0.32 and finally everything worked, just as @devlove merntioned . so, if you are having troubles with the package from the asset store, try 0.32 until whatever the problem is gets fixed.

1 Like

Thanks @swampmonster for additional information.

That is exactly what I encountered and tried to resolve the problem.
I’m disappointed to be forced to use 0.32, because I bought lisence with Nuitrack AI. Which is supported only since 0.33 :frowning:

SDK from may be broken.
In that case, try one from the Installation Instructions.

I can confirm the error when using nuitrack 0.33 with the Unity package. The 0.33 update would be essential for us, but we are forced to wait for fix or look for other alternatives.

I was able to get 33 working with unity3d. However, it required a totally meticulous management of the software environment. If you don’t have it perfect you will be sent on a wild goose chase.

  1. in general this is true with many SDKs that rely on other SDKs, BUT IN THIS CASE ITS VERY SERIOUS: you need to have the latest realsense sdk version+ the exact same version of the nuittrack unity package and nuitrack sdk. All three need to be synchronized or it will have problems with unhelpful error messages.

  2. how do we know if the AI feature is working? Is this automatic and applied to all calls to the sdk or do we need do something specific to make the AI work… i have not noticed any improvement in tracking since we upgraded to the AI version so i am guessing its not enabled.

1 Like
  1. I installed the latest Nuitrack runtime (0.33) and the lastest realsense SDK (2.38.1) and it’s still not working. Where did you download the SDK/Unity package? It seems their git page have SDK with 0.32 as description, but they also have gitlab with Nuitrack v0.33.0 as SDK title. What is more comfusing that the corresponding sdk versions are 1.7.0 and 1.8.0 when looking at the version file.
    So with Nuitrack 0.33 what version of realsense SDK and nuitrack SDK / Unity plugin should I install?

  2. The differences I noticed so far were that when enabling AI tracking from activation tool the the sample app’s CPU usage more than doubled. Other thing I noticed was that obscured joints disappeared where as in 0.32 they turned blue and their position was still estimated (which was better).

@swampmonster, please send us the screenshot of errors in the Unity log. It seems that you could have cloned a repository without lfs-dependencies.

Please take a look at this topic: Compatibility of the latest Nuitrack runtime and SDK versions

the newest versions worked for me.
thanks @iosif.semenyuk

yet no response for my issue Nuitrack works on Unity Editor, but not when building the game

great plugin definately gonna pay for the subscription