Nuitrack SDK works on the editor but doesn't work on Build

Basically, I tried everything the forum is saying but still have this problem.
I tried both unity 2020 and 2021. I received the attached error when I’m building the allmodule scene but everything works in the editor.

Hello @Nima
Make sure that your sensor is not used in another program.
And attach Player.Log

Thanks for the reply.
I’m not using the sensor with any other program. I removed the sensor from intel realsense viewer as well.

“If not, try start C:\Program Files\Nuitrack\nuitrack\nuitrack\bin\nuitrack_sample.exe” does it mean I should run it before running my unity build?

here’s the Player.Log:
Mono path[0] = ‘C:/Users/User/Desktop/New folder (3)/mApp_Data/Managed’
Mono config path = ‘C:/Users/User/Desktop/New folder (3)/MonoBleedingEdge/etc’
Initialize engine version: 2021.1.1f1 (6fdc41dfa55a)
[Subsystems] Discovering subsystems at path C:/Users/User/Desktop/New folder (3)/mApp_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1; jobified=1
Version: Direct3D 11.0 [level 11.1]
Renderer: NVIDIA GeForce GTX 1080 Ti (ID=0x1b06)
Vendor: NVIDIA
VRAM: 11127 MB
Begin MonoManager ReloadAssembly

  • Completed reload, in 1.503 seconds
    D3D11 device created for Microsoft Media Foundation video decoding.
    Initializing input.

Input initialized.

Initialized touch support.

UnloadTime: 0.719400 ms
<color=red>Perhaps the sensor is already being used in other program.
If not, try start C:\Program Files\Nuitrack\nuitrack\nuitrack\bin\nuitrack_sample.exe

<color=red>Also look Nuitrack Troubleshooting
If all else fails and you decide to contact our technical support, do not forget to attach the Unity Editor Log File (in %LOCALAPPDATA%/Unity/Editor) and specify the Nuitrack version

nuitrack.TerminateException: NuitrackException (TerminateException): WARNING: Cannot load library module: C:\Program Files\Nuitrack\nuitrack\nuitrack/middleware/NuitrackModule.dll
ERROR: TBB version mismatch: runtime library version is 10003, but the application was compiled with the 11102 version!
Please refer to
at nuitrack.NativeImporter.throwException (nuitrack.NativeImporter+ExceptionType type, System.String message) [0x00055] in <0fa84b5c91c943e190b9d848b3950060>:0
at nuitrack.NativeImporter.handleError (System.IntPtr error) [0x00061] in <0fa84b5c91c943e190b9d848b3950060>:0
at nuitrack.NativeNuitrack.Init (System.String config) [0x0000e] in <0fa84b5c91c943e190b9d848b3950060>:0
at nuitrack.Nuitrack.Init (System.String config, nuitrack.Nuitrack+NuitrackMode mode) [0x00029] in <0fa84b5c91c943e190b9d848b3950060>:0
at NuitrackManager.NuitrackInit () [0x00067] in <47470c62c4b243239b10e573791c6d71>:0

Setting up 4 worker threads for Enlighten.
Thread -> id: 1828 -> priority: 1
Thread -> id: 350c -> priority: 1
Thread -> id: 2d8c -> priority: 1
Thread -> id: 39bc -> priority: 1

1 Like

I still have this problem when running the build file. any ideas on how to solve it?

I’ve not dug into this extensively since I still have a trial license and thought that may be the cause. In unity editor, the app doesn’t crash (perf is another story, working on that next). When I create a build, it seems to run for 30-60 seconds then crash. I’ll dig into that later too and report back any logs I find - just wanted to mention I’ve had same/similar issues recently. Unity v2021.1.21f1

Do you think the problem is with the trial version? cause I’m using the trial version as well.

ERROR: TBB version mismatch: runtime library version is 10003, but the application was compiled with the 11102 version!

Troubleshooting page

  1. You replaced tbb.dll in the editor’s folder?
  2. If so, try deleting the build folder. And try to build your project again.

Hi Stephan,
Yes, I’ve already replaced the tbb.dll file and removed the library from the project’s folder to clean up everything just in case. and still no luck.

Im not Stephan, but ok

Try to build in “build_test2” folder. Archive it and send it if possible

Dear Stepan,
Sorry for the misspelling :slight_smile:
here’s the link to the build inside a fresh folder

1 Like

hm… your build worked for me

Yes, It runs perfectly on the editor but not in the build. should I run something before launching the build?
I’m sure I’m not running any programs that used the Nuitrack while launching the build. I even closed the unity editor before launching the build. is it related to the trial version?

should I run something before launching the build?

No. Usually if it works in the editor it should work in the build as well

is the build done in version 2021.1? Does the AllModulesScene scene run in the version 2021.1 editor?
Send a screenshot of the entire screen with the running scene (in Unity Editor)

Yes, I’m using unity 2021.1.1f1. and realsense D415. is there a way I can check if a nuitrack activity is running while I’m launching the build? I doubt it but just in case.

What is the nuitrack version?
If not the latest version (v0.35.9) then you need to update.
And send a screenshot of the running build “build_test2”

Dear Stepan,
yes I’m using the latest version of Nuitrack 0.35.9.

ok, it looks like the problem is in the TBB file from the nuitrack folder, maybe it was accidentally replaced
Program Files\Nuitrack\nuitrack\nuitrack\bin\nuitrack_sample.exe worked?
Try reinstall Nuitrack.
Or try replace tbb.dll (original file: in Nuitrack folder “Program Files\Nuitrack\nuitrack\nuitrack\bin” (and replace tbb.dll in Unity Editor folder)

Dear Stepan,
I re-installed the Nuitrack, replaced the tbb from the nuitrack and the unity editor. and built again. still no luck. the same error appears.

Hm. Try this build (and send screenshot)

Same error as mine.