[Solved] RealSense D415 + Windows 10 x64. Crash on startup

Hello there,

I’m currently evaluating Nuitrack. We are interesting in adding gesture recognition to our software packages. I have seen the C# option in your SDK and this looks really useful. I’m afraid that I’m having problems however in getting the sample projects to run properly. Both “nuitrack_sample.exe” and the C# example start and then crash shortly after showing their windows.

I’ve installed Nuitrack following the instructions here

I’m using an Intel RealSense D415 firmware and the camera works well with both RealSense viewer and with the RealSense SDK.

The samples located in the “nuitrack\bin” result in the following:

Create DepthProvider: RealSense2DepthProvider
terminate called after throwing an instance of ‘tdv::nuitrack::TerminateException’
what(): Realsense2DepthProvider: rs2_set_option(options:00000000D2DB650, option:Visual Present, value:5): get_xu(id=10) failed! Last Error: No error

The camera starts to work as I can see the red lasers activating.
I’m afraid that I cannot give the error for the C# sample as this is not on the screen long enough to read.

I would appreciate any help that you can give.

Kind regards,
Karl Abson

I had similar issue, what version of RealSense SDK are you using?

I’m using 2.16.5. Is it possible that it’s too new?

Check this topic:

Yes I have seen and read this thread. The error messages are different, the situation and OS are also different. I don’t think the causes are related.

I don’t know…the camera works fine with the Intel software and the SDK. I would like someone from Nuitrack to comment on the error messages.

Leave a error message a side. see the the SDK version number that works with Nuitrack.

Current Nuitrack version is compiled with RealSense SDK version 2.15.0

I have installed 2.15.0 RealSense version on Windows 10 and it works

Yes that’s a good point. I read that it is currently made with 2.15.0. I’ll download and install the older version. Its worth a try.

No joy I’m afraid but thanks for the suggestion…it’s the same result with 2.15.0.

Nuitrack starts to run, it connects to the camera as I can see the lasers activate. It then however terminates with a “TerminateException”, screenshot attached.

I’m now using 2.15.0. I found a video of how to install Nuitrack and I can confirm everything was followed correctly. All the Intel examples work without issue.

Very strange and I’m out of ideas…

Finally I found the solution :wink: I simply switched from one USB port to another.
It’s very strange, both the original and new ports are identical.