Ubuntu and Intel RealSense D415 issues


I am trying to install Nuitrack 0.28 with Ubuntu 16 and Intel RealSense D415.
Realsense-viewer works fine, however I have issues with Nuitrack:

  • nuittrack_license_tool does not let me enter the activation code. When I run the compatibility test, it opens a new window showing a screen capture from my desktop.

  • nuitrack_sample also shows a window with a screen capture. In the terminal windows it shows these messages:

    WARNING: Can not load library module: /usr/etc/nuitrack/middleware/libNuitrackModule.so
    ERROR: Empty factory for DepthProvider
    Empty factory for DepthProvider

Please help.

Hi Joaquim,

Please run the command below and provide us with the output:

ldd /usr/etc/nuitrack/middleware/libNuitrackModule.so | grep not

Hi Olga,

This is the output of the command you asked for:
libcurl.so => not found

However I have curl installed in my system.
Which vesrsion of libcurl is required?


Please run the command:

sudo apt-get install libcurl4-openssl-dev

Thanks, I found a thread in the forum of another user that had similar libcurl problem Ubuntu installtion

I also had the same problem with $(logname) which seems that is empty since Ubuntu version 16 for security reasons.

I have managed to activate my license and run nuitrack_sample with Intel D415.

I have a another question: I tried first Ubuntu 18 and then downgrade to 16 when I found th Nuitrack installation issues. Now that I see that the issues were not related to Ubuntu version I would like to go back to Ubuntu 18.
Do I have to deactivate the license to install it in another system or the license is linked to the sensor?

Thanks again

What license do you use?

  • If you use Nuitrack Pro Online or Nuitrack Pro Perpetual, you just need to re-activate the license (for Perpetual: use the same sensor).
  • If you use Nuitrack Trial, you have to generate a new trial key in your personal account and activate it.

I am using Trial. I requested a new trial key.
Thank you!