Unity3D crashes on play

I posted about two weeks ago about Unity’s instant close/crash issue. It wasn’t really a “crash” that comes with a crash report, so I didn’t call it a crash at that time. But it “crashed” today, and there’s a crash report, so I decided to start a new post for help.

For the earlier post, you can check here.

  • OS: x64 Windows 10 Home
  • Nuitrack Runtime: 0.35.12
  • Nuitrack License: Trial License
  • Unity Editor: 2020.3.25f1
  • Sensor: Orbbec Astra Pro
  • Project is run as admin

The instant close or crash can happen at different times when I start a project with Nuitrack SDK, or I run a scene with Nuitrack SDK. So far, I have discovered three spots where this happens.

  • When a Unity Project with Nuitrack SDK is being started, only instant close happened.
  • When a Unity Scene with Nuitrack SDK is being played, both instant close and crash happened.
  • When a script is edited, after I switched back to Unity, both happened.

Sometimes, I can play a scene without any issue, but when I play it the second time, it crashes/closes.

I also tried to run the same scene on another desktop, and this never happened. However, there’s another issue that I will post in another topic.

The Editor.log and crash.dmp are uploaded to my Dropbox, you can find it here.

Hello @Sean
Do you have these crashes if the sensor is not connected?

Hello @Stepan.Reuk

No, if the sensor is not connected and I run the scene, it won’t crash.

And if I now connect the sensor to the PC, it seems that everything works fine. I tried several scenes after that, and there were no crashes. But after I restarted the Unity editor, it started to crash again if I ran a scene (with the connected sensor).

I recommend updating our unity package: https://github.com/3DiVi/nuitrack-sdk/tree/master/Unity3D

Hello @Sean
Did it help?

Hello @Stepan.Reuk,

Sorry for the late reply, and yes, it did help with the crashing problem.

1 Like