Intel RealSense D435 with Nuitrack

Please follow the instructions from NuitrackSDK/Examples/nuitrack_csharp_sample/README.txt
Also provide us with the screenshot of the error.

This is the error when I pressed the “configure” button. And I’m using MS visual studio code 2017 community version

Please use Visual Studio instead of Visual Studio Code.

Sorry, it was my typo. I’m using Visual Studio 2017, may I know how to solve the error?

Please download Build Tools for Visual Studio 2017.

Hi, I can run the CMake now. Btw this is the messages shown. Is it important for my work?

Then I followed the steps in README file, open the Project.sln in VS, move the .exe file to its parent directory and this message came out.

Unhandled Exception: System.DllNotFoundException: Unable to load DLL 'libnuitrack': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
   at nuitrack.NativeImporter.nuitrack_InitializeFromConfig(String config)
   at nuitrack.NativeNuitrack.Init(String config)
   at nuitrack.MainForm..ctor()
   at nuitrack.Program.Main()

Sorry for so many questions. I really appreciate your guide since I’m totally new to it. Thanks.

I couldn’t manage to change to x64 in the project properties

If you select the setup project in solution explorer and click F4 you should see the properties window with AddRemoveProgramsIcon, Manufacturer and so on. Down that list is TargetPlatform where you should specify x64.

Is it like this? But I still get the same error with the modification.

This is what I get from my task manager. Is that my VS version not suitable?
But I have reinstalled again, it appears 32bit as well.

You can use 32-bit version of Visual Studio. However, when configuring the project, you have to select a 64-version of VS compiler. Please see the picture below:


Hi, Yes, I have tried again with choosing the Visual Studio 15 2017 Win64 during CMake.
But the error still exists. So, I would like to describe my steps so that it is easier for you to know where is my problem.

In the README file,

  1. Open solution "Project.sln" in Visual Studio and use its instruments to build solution
    Am I required to build the solution for all 4 projects namely "ALL_BUILD, INSTALL, nuitrack_csharp_sample and ZERO_CHECK"?

  2. copy .exe binary from "build" directory to its parent folder (or build target INSTALL) and run sample from "nuitrack_csharp_sample" directory
    After building the solution of the 4 projects, nuitrack_csharp_sample.exe has appeared. Then I move the .exe file to the parent folder (from NuitrackSDK\Examples\nuitrack_csharp_sample\build to NuitrackSDK\Examples\nuitrack_csharp_sample), but the error still exists.

  3. May I know about the setting over here? In configuration manager

Thanks a lot for the assistance you provided previously. Really appreciate it :smile:

Hi, kindly read the information above :slight_smile:

Did you install Nuitrack Runtime component? See the installation instructions for Windows.

I have download and Visual C++ Redistributable 2017 (x64) and also setup the environment variables also.

Please check our standard samples from Nuitrack SDK (for example, nuitrack_c11_sample), do they work?

Yes. It works. Btw, I have removed all files and begin again.
May I know the environment variable settings? The instructions are confusing. Should I add the value of \nuitrack or \nuitrack\bin to the PATH environment variable.


Please specify what part of instructions is confusing?

  1. Create an environment variable with the name of NUITRACK_HOME and value of install-folder\nuitrack.
  2. Add install-folder\nuitrack\bin to the PATH environment variable (yes, you have to add the path to the \nuitrack\bin folder).

You can also take a look at our Nuitrack Installation Video Tutorial. In this video, we show how to add and edit the environment variables.

Hi, was busy last few months.
I have successfully obtained this from the csharp_sample.exe

May I know how can I use the Proj or Real properties to get the coordinates?
I need the coordinates to be exported into an excel file.

Thanks for your help :slight_smile:

Please take a look at my reply that I’ve posted earlier: